Error: docker-engine-selinux conflicts with 2:container-selinux?

centos系统中安装docker时报如下错误:

Error: docker-engine-selinux conflicts with 2:container-selinux-1.10.3-59.el7.centos.x86_64

 You could try using --skip-broken to work around the problem

该如何解决?

1个回答

我也遇到过同样的问题,首先删除之前已经安装的docker

# yum remove docker*

查找并删除container-selinux

# rpm -qa | grep container-selinux
container-selinux-1.10.3-59.el7.centos.x86_64
# yum remove container-selinux
36nu 分享编程知识及经验

已有账号?立即登录
微信公众号
关注36nu微信公众账号
获取最新编程知识及经验